diff options
author | Ralph Amissah <ralph@amissah.com> | 2014-10-12 10:56:59 -0400 |
---|---|---|
committer | Ralph Amissah <ralph@amissah.com> | 2014-10-12 10:56:59 -0400 |
commit | 2e4c214d4d2323864985ccfe93346a9796edee2f (patch) | |
tree | bd450b52b31b81fc46150ebee9d4e06bc7e1e560 /bin | |
parent | debian/changelog (5.6.9-1) (diff) | |
parent | v5: merge v6: remove defaults.rb & some relics related to sisu skins (diff) |
Merge tag 'sisu_5.7.0' into debian/sid
SiSU 5.7.0
Diffstat (limited to 'bin')
-rw-r--r-- | bin/sisu | 20 |
1 files changed, 10 insertions, 10 deletions
@@ -94,22 +94,22 @@ class Orient if sisu_run_from == :full_path_to_sisu_bin_in_sisu_dir_tree \ or sisu_run_from == :system_install case processing.called_as - when processing.stable_bin_file_regex then processing.stable - when processing.unstable_bin_file_regex then processing.unstable + when processing.stable_bin_file_regex then processing.stable + when processing.unstable_bin_file_regex then processing.unstable else case processing.argv_str - when processing.stable_modifier_regex then processing.stable - when processing.unstable_modifier_regex then processing.unstable - else processing.default + when processing.stable_modifier_regex then processing.stable + when processing.unstable_modifier_regex then processing.unstable + else processing.default end end elsif sisu_run_from == :gem_install case processing.file_full_path - when processing.stable_gem_regex then processing.stable - when processing.unstable_gem_regex then processing.unstable - else processing.default + when processing.stable_gem_regex then processing.stable + when processing.unstable_gem_regex then processing.unstable + else processing.default end - else processing.default + else processing.default end end def paths_set @@ -263,7 +263,7 @@ class Orient end rescue ensure - SiSU::HubClose.new(sisu_called_from_directory) + SiSU::HubClose.new(sisu_called_from_directory,@argv) Dir.chdir(sisu_called_from_directory) system("cd #{sisu_called_from_directory}") end |