aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/sst_convert_markup.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2012-12-12 14:58:58 -0500
committerRalph Amissah <ralph@amissah.com>2012-12-12 14:58:58 -0500
commit1beb5aa3c376dbef89bc33024216650529ef7262 (patch)
tree1682500089c14fd49bcf52a3a001e291fadd5f75 /lib/sisu/v3/sst_convert_markup.rb
parentdebian/changelog (3.3.2-1) (diff)
parentv3: 3.3.3 version & changelog, dates touched (diff)
Merge tag 'sisu_3.3.3' into debian/sid
Diffstat (limited to 'lib/sisu/v3/sst_convert_markup.rb')
-rw-r--r--lib/sisu/v3/sst_convert_markup.rb14
1 files changed, 7 insertions, 7 deletions
diff --git a/lib/sisu/v3/sst_convert_markup.rb b/lib/sisu/v3/sst_convert_markup.rb
index 6b224ddb..20b6d775 100644
--- a/lib/sisu/v3/sst_convert_markup.rb
+++ b/lib/sisu/v3/sst_convert_markup.rb
@@ -196,7 +196,7 @@ WOK
and @opt.files.length > 0
mr=nil
#%% changes to make m match, r replace -------------------------->
- if @opt.mod.inspect =~/--help/; help
+ if @opt.mod.inspect =~/--help/ then help
elsif @opt.mod.inspect =~/(?:convert|to)[=-](?:xml |sxs|sax|sxd|dom|sxn|node)/
ext=case @opt.mod.inspect
when /(?:convert|to)[=-](?:xml|sxs|sax)/; '.sxs.xml'
@@ -272,13 +272,13 @@ WOK
end
end
end
- if y=~/^\s*$/; @empty1=true
- else @empty1=false
- end
+ @empty1=(y=~/^\s*$/) \
+ ? true
+ : false
@file.puts y unless (@empty1==true and @empty2==true)
- if y=~/^\s*$/; @empty2=true
- else @empty2=false
- end
+ @empty2=(y=~/^\s*$/) \
+ ? true
+ : false
end
@file.close
else puts "NO conversion match in #{i}" unless @opt.cmd=~/q/