aboutsummaryrefslogtreecommitdiffhomepage
path: root/lib/sisu/v3/sysenv.rb
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2013-01-05 21:53:52 -0500
committerRalph Amissah <ralph@amissah.com>2013-01-05 21:53:52 -0500
commit65adfcc0343ed43c5c646d9fc8707f5e4ba8e477 (patch)
tree237703d730f222e9e42cb03259eac32c6c81b34f /lib/sisu/v3/sysenv.rb
parentdebian/changelog (4.0.0-1) [posted to experimental, awaiting Wheezy freeze end] (diff)
parentdate 2013: version & changelog; headers bin/sisu & lib/; code constants.rb (diff)
Merge tag 'sisu_4.0.1' into debian/sid
Diffstat (limited to 'lib/sisu/v3/sysenv.rb')
-rw-r--r--lib/sisu/v3/sysenv.rb6
1 files changed, 4 insertions, 2 deletions
diff --git a/lib/sisu/v3/sysenv.rb b/lib/sisu/v3/sysenv.rb
index c4b364ad..bfe35c5d 100644
--- a/lib/sisu/v3/sysenv.rb
+++ b/lib/sisu/v3/sysenv.rb
@@ -8,7 +8,7 @@
* Author: Ralph Amissah
* Copyright: (C) 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006,
- 2007, 2008, 2009, 2010, 2011, 2012 Ralph Amissah, All Rights Reserved.
+ 2007, 2008, 2009, 2010, 2011, 2012, 2013 Ralph Amissah, All Rights Reserved.
* License: GPL 3 or later:
@@ -3499,7 +3499,9 @@ WOK
@env_rc ||=SiSU_Env::InfoEnv.new(@md.fns)
end
def doc_rc #document rc, make instructions
- @md.make
+ (defined? @md.make) \
+ ? @md.make
+ : nil
end
def cmd_rc_act #command-line rc
@cmd_rc_act=@md.opt.opt_act