aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2020-09-02 11:52:15 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2020-10-19 13:41:43 -0400
commite1923108945cdf18ef7d910b7a7946164059c94f (patch)
tree084a84e2969b78f170ac512e2fceae9450add13e /shell.nix
parent0.11.1 (diff)
shell.nix
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..5b97ffe
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,19 @@
+{ pkgs ? import <nixpkgs> {} }:
+
+with pkgs;
+
+mkShell {
+ buildInputs = with pkgs; [
+ ninja dub
+ meson git
+ ldc #ldc dmd gdc
+ sqlite
+ validatePkgConfig
+ #gnumake gcc gdc cmake
+ #dzen2
+ ];
+ shellHook = ''
+ echo `ldc2 --version`
+ '';
+ COMPILER = "ldc2";
+}