aboutsummaryrefslogtreecommitdiffhomepage
path: root/subprojects/imageformats/meson.build
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2020-02-07 10:52:16 -0500
committerRalph Amissah <ralph@amissah.com>2020-03-06 15:13:53 -0500
commit503412b02356cd0dd92f0fc0900f48eab3afce24 (patch)
tree0e8ee05bcb814db5d414386c42fd9cd64804d892 /subprojects/imageformats/meson.build
parentlatex outputs (various paper sizes & orientation) (diff)
meson build
Diffstat (limited to 'subprojects/imageformats/meson.build')
-rw-r--r--subprojects/imageformats/meson.build40
1 files changed, 40 insertions, 0 deletions
diff --git a/subprojects/imageformats/meson.build b/subprojects/imageformats/meson.build
new file mode 100644
index 0000000..584e2af
--- /dev/null
+++ b/subprojects/imageformats/meson.build
@@ -0,0 +1,40 @@
+project('imageformats', 'd',
+ meson_version: '>=0.46',
+ license: 'BSL-1.0',
+ version: '7.0.0'
+)
+
+project_soversion = '0'
+
+src_dir = include_directories('.')
+pkgc = import('pkgconfig')
+
+imageformats_src = [
+ 'imageformats/bmp.d',
+ 'imageformats/jpeg.d',
+ 'imageformats/package.d',
+ 'imageformats/png.d',
+ 'imageformats/tga.d'
+]
+install_subdir('imageformats/', install_dir: 'include/d/imageformats-d/')
+
+imageformats_lib = library('imageformats-d',
+ [imageformats_src],
+ include_directories: [src_dir],
+ install: true,
+ version: meson.project_version(),
+ soversion: project_soversion
+)
+
+pkgc.generate(name: 'imageformats-d',
+ libraries: imageformats_lib,
+ subdirs: 'd/imageformats-d/',
+ version: meson.project_version(),
+ description: 'Decoders for PNG, TGA, BMP, JPEG and encoders for PNG, TGA, BMP.'
+)
+
+# for use by others which embed this as subproject
+imageformats_dep = declare_dependency(
+ link_with: [imageformats_lib],
+ include_directories: [src_dir]
+)