aboutsummaryrefslogtreecommitdiffhomepage
path: root/sundry/spine_search_cgi/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-10-23 19:49:43 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2021-11-27 19:51:25 -0500
commitc4f6c86999ec8fe3b610ac269a121c9fa424daf5 (patch)
tree9251611c030c29af99bfa59bda94521c3500ad94 /sundry/spine_search_cgi/shell.nix
parentnix .envrc related (diff)
dlang dub & nix build related, includes dep update
- nix-shell --pure - nix-build - dub build --compiler=ldc2 --build=release --force
Diffstat (limited to 'sundry/spine_search_cgi/shell.nix')
-rwxr-xr-xsundry/spine_search_cgi/shell.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/sundry/spine_search_cgi/shell.nix b/sundry/spine_search_cgi/shell.nix
index 55ca4ae..8a73316 100755
--- a/sundry/spine_search_cgi/shell.nix
+++ b/sundry/spine_search_cgi/shell.nix
@@ -1,7 +1,8 @@
#!/usr/bin/env -S nix-shell --pure
{ pkgs ? import <nixpkgs> {} }:
-pkgs.mkShell {
- buildInputs = with pkgs; [
+with pkgs;
+mkShell {
+ buildInputs = [
# nix_related
nixFlakes
nix-prefetch-git
@@ -13,7 +14,6 @@ pkgs.mkShell {
dub
ldc
#meson
- # search_sqlite_related
# search related
sqlite
# candy