diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 21 |
1 files changed, 13 insertions, 8 deletions
@@ -3,9 +3,6 @@ inputs = { flake-utils.url = "github:numtide/flake-utils"; nixpkgs.url = "/nixpkgs-ra/nixpkgs/.gitworktree/ra/nixpkgs"; - # pkgs /nixpkgs-ra/nixpkgs/.gitworktree/ra/nixpkgs {} - #spine.url = "/grotto-ra/repo/git.repo/projects/project-spine/doc-reform"; - #spine.url = "./."; d2sqlite3 = { url = "github:dlang-community/d2sqlite3"; flake = false; @@ -27,11 +24,19 @@ flake = false; }; }; - outputs = { self, nixpkgs, flake-utils }: - flake-utils.lib.simpleFlake { - #flake-utils.lib.spine { - inherit self nixpkgs; + outputs = { self, d2sqlite3, tinyendian, dyaml, imageformats, dub2nix-src, nixpkgs, flake-utils }: + let + pkgs = nixpkgs.legacyPackages.x86_64-linux; + in { + packages.x86_64-linux.spine = pkgs.stdenv.mkDerivation { name = "spine"; - #shell = ./shell.nix; + inherit self; + src = self; + shell = ./shell.nix; + installPhase = '' + install -m755 spine $out/bin/spine + ''; }; + defaultPackage.x86_64-linux = self.packages.x86_64-linux.spine; + }; } |