aboutsummaryrefslogtreecommitdiffhomepage
path: root/nix/shell/shell_spine.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/shell/shell_spine.nix')
-rwxr-xr-xnix/shell/shell_spine.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/nix/shell/shell_spine.nix b/nix/shell/shell_spine.nix
new file mode 100755
index 0000000..0c0deb6
--- /dev/null
+++ b/nix/shell/shell_spine.nix
@@ -0,0 +1,18 @@
+{ pkgs ? import <nixpkgs> {} }:
+pkgs.mkShell {
+ buildInputs = with pkgs; [
+ (import ../pkglst/shell-pkgs.nix { inherit pkgs; })
+ ];
+ buildPhase = "nix build -f default.nix";
+ shellHook = ''
+ if [[ -e ".envrc" ]]; then
+ source .envrc
+ fi
+ nix-build
+ RUN="./result/bin/spine --very-verbose --theme-light --html --epub --sqlite-discrete --output=/tmp/www ./data/pod/sisu-markup"
+ $RUN
+ echo "built spine ... @ ./result/bin/spine"
+ echo "& (tested with) run:"
+ echo " $RUN"
+ '';
+}