aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/shell.nix b/shell.nix
index d90aa6c..4093de6 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,7 @@
#!/usr/bin/env -S nix-shell --pure
#!nix-shell -i bash
-{pkgs ? import <nixpkgs> {}}:
-with pkgs;
+{pkgs-nix ? import <nixpkgs> {}}:
+with pkgs-nix;
mkShell {
buildInputs = [
# ❯❯❯ nix_related
@@ -13,16 +13,17 @@ with pkgs;
nix-output-monitor
nix-tree
jq #gx
- alejandra
+ #alejandra
git
# ❯❯❯ dev
gnumake
ps
# ❯❯❯ d_build_related
# ❯❯ package manager
- dub
+ #dub
# ❯❯ compiler
- ldc
+ #dmd
+ #ldc
#rund
# ❯❯ linker
#lld
@@ -31,7 +32,7 @@ with pkgs;
#ninja
#meson
# ❯❯❯ sqlite search related
- sqlite
+ #sqlite
# ❯❯❯ pdf_latex_related
# source-sans-pro
# source-serif-pro