aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/shell.nix b/shell.nix
index 48b87d1..0ac55ea 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,8 @@
#!/usr/bin/env -S nix-shell --pure
{ pkgs ? import <nixpkgs> {} }:
-pkgs.mkShell {
- buildInputs = with pkgs; [
+with pkgs;
+mkShell {
+ buildInputs = [
# nix_related
nixFlakes
nix-prefetch-git
@@ -13,11 +14,8 @@ pkgs.mkShell {
dub
ldc
#meson
- # candy
- starship
- # # search_sqlite_related
- # # search related
- # sqlite
+ # search related
+ sqlite
# # pdf_latex_related
# source-sans-pro
# source-serif-pro
@@ -33,6 +31,8 @@ pkgs.mkShell {
# sigil
# calibre # (ebook-viewer)
# foliate
+ # candy
+ starship
];
shellHook = ''
if [[ -e ".envrc" ]]; then