aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 17ccd5b..c2e52a6 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,4 +1,3 @@
-#!/usr/bin/env -S nix-shell
{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
buildInputs = with pkgs; [
@@ -7,6 +6,9 @@ pkgs.mkShell {
buildPhase = "nix build -f default.nix";
shellHook = ''
echo "built spine @ ./result/bin/spine"
+ if [[ -e ".envrc" ]]; then
+ source .envrc
+ fi
#nix-instantiate | nix show-derivation | jq
'';
}