diff options
Diffstat (limited to 'shell.nix')
-rwxr-xr-x | shell.nix | 29 |
1 files changed, 14 insertions, 15 deletions
@@ -1,20 +1,19 @@ +#!/usr/bin/env -S nix-shell --pure { pkgs ? import <nixpkgs> {} }: pkgs.mkShell { - buildInputs = with pkgs; [ - ( - with pkgs; [ - nixFlakes - rund - dub - ldc - sqlite - nix-prefetch-git - validatePkgConfig - jq - git - ] - ) - ]; + buildInputs = with pkgs; [( + with pkgs; [ + nixFlakes + rund + dub + ldc + sqlite + nix-prefetch-git + validatePkgConfig + jq + git + ] + )]; shellHook = '' if [[ -e ".envrc" ]]; then source .envrc |