aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix24
1 files changed, 14 insertions, 10 deletions
diff --git a/shell.nix b/shell.nix
index b226cd3..31cfcfb 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,17 +1,21 @@
{ pkgs ? import <nixpkgs> {
overlays = [
(import ./nixDevEnv/overlays/ldcVersion.nix)
- (import ./nixDevEnv/overlays/dmdVersion.nix)
]; }
}:
- pkgs.mkShell {
- buildInputs = with pkgs; [
- dub
- ninja
- #meson
- dmd
- ldc
- sqlite
- validatePkgConfig
+let
+ dub2nix-src = fetchTarball {
+ url = "https://github.com/lionello/dub2nix/archive/master.tar.gz";
+ };
+ dub2nix = (import dub2nix-src) { inherit pkgs; };
+in pkgs.mkShell {
+ buildInputs = with pkgs; [
+ nix
+ dub
+ ldc
+ rdmd
+ sqlite
+ dub2nix
+ nix-prefetch-git
];
}