diff options
Diffstat (limited to 'shell.nix')
-rwxr-xr-x | shell.nix | 4 |
1 files changed, 3 insertions, 1 deletions
@@ -1,4 +1,3 @@ -#!/usr/bin/env -S nix-shell { pkgs ? import <nixpkgs> {} }: pkgs.mkShell { buildInputs = with pkgs; [ @@ -7,6 +6,9 @@ pkgs.mkShell { buildPhase = "nix build -f default.nix"; shellHook = '' echo "built spine @ ./result/bin/spine" + if [[ -e ".envrc" ]]; then + source .envrc + fi #nix-instantiate | nix show-derivation | jq ''; } |