#!/usr/bin/env -S nix-shell --pure
{ pkgs ? import <nixpkgs> {} }:
with pkgs;
mkShell {
  buildInputs = [
    ### nix_related
    nixFlakes
    nix-prefetch-git
    validatePkgConfig
    jq
    git
    ### d_build_related
    ## package manager
    dub
    ## compiler
    ldc
    rund
    ## linker
    #lld
    #mold
    ## builder
    #ninja
    #meson
    ### sqlite search related
    sqlite
    # ### pdf_latex_related
    # source-sans-pro
    # source-serif-pro
    # source-code-pro
    # texlive.combined.scheme-full
    # ### xml_and_epub_related
    # libxml2
    # html-tidy
    # xmlstarlet
    # epubcheck
    # ebook_tools
    # epr
    # sigil
    # calibre #(suite includes: ebook-viewer)
    # foliate
    # ### i18n translation related
    # perl534Packages.Po4a
    ### candy
    starship
  ];
  shellHook = ''
    if [[ -e ".envrc" ]]; then
      source .envrc
    fi
    eval "$(starship init bash)"
  '';
}