{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
  buildInputs = with pkgs; [
    (import ./nix/pkglst/shell-pkgs.nix { inherit pkgs; })
  ];
  buildPhase = "nix build -f default.nix";
  shellHook = ''
    echo "built spine @ ./result/bin/spine"
    if [[ -e ".envrc" ]]; then
      source .envrc
    fi
    #nix-instantiate | nix show-derivation | jq
  '';
}