aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2025-01-31 22:50:18 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2025-01-31 22:50:18 -0500
commitc894c36fe6cd0eba504d572854c89d07af31aaa2 (patch)
tree98def15d54092ee43e015315e762b1d9450be3ca /flake.nix
parentsisu nix package/config updates, ruby on nix current (diff)
nix minorHEADupstream
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix52
1 files changed, 26 insertions, 26 deletions
diff --git a/flake.nix b/flake.nix
index 0456f1b..89fa050 100644
--- a/flake.nix
+++ b/flake.nix
@@ -10,12 +10,12 @@
nixpkgs,
sisu
} @ inputs: let
- version = "0.7.3";
+ version = "7.3.1";
shell = ./shell.nix; # ./default.nix;
devEnv = ./.envrc; # ./.envrc; # ./shell.nix; # ./default.nix;
supportedSystems = [ "x86_64-linux" ]; # [ "x86_64-linux" "x86_64-darwin" "aarch64-linux" "aarch64-darwin" ];
forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
- nixpkgsFor = forAllSystems (system: import nixpkgs { inherit system; }); # nixpkgs instantiated for supported system types.
+ nixpkgsFor = forAllSystems (system: import nixpkgs { inherit system; }); # nixpkgs instantiated for supported system types
in {
packages = forAllSystems (system: let
pkgs = nixpkgsFor.${system};
@@ -65,10 +65,10 @@
inherit shell;
inherit devEnv;
packages = [
- ruby_3_4
- rubyPackages_3_4.rake
- rubyPackages_3_4.sqlite3
- rubyPackages_3_4.thor
+ ruby
+ rubyPackages.rake
+ rubyPackages.sqlite3
+ rubyPackages.thor
sqlite
jq
git
@@ -80,10 +80,10 @@
inherit shell;
inherit devEnv;
packages = [
- ruby_3_4
- rubyPackages_3_4.rake
- rubyPackages_3_4.sqlite3
- rubyPackages_3_4.thor
+ ruby
+ rubyPackages.rake
+ rubyPackages.sqlite3
+ rubyPackages.thor
sqlite
graphicsmagick
zip
@@ -114,10 +114,10 @@
inherit shell;
inherit devEnv;
packages = [
- ruby_3_4
- rubyPackages_3_4.rake
- rubyPackages_3_4.sqlite3
- rubyPackages_3_4.thor
+ ruby
+ rubyPackages.rake
+ rubyPackages.sqlite3
+ rubyPackages.thor
sqlite
graphicsmagick
zip
@@ -134,10 +134,10 @@
inherit shell;
inherit devEnv;
packages = [
- ruby_3_4
- rubyPackages_3_4.rake
- rubyPackages_3_4.sqlite3
- rubyPackages_3_4.thor
+ ruby
+ rubyPackages.rake
+ rubyPackages.sqlite3
+ rubyPackages.thor
sqlite
graphicsmagick
zip
@@ -161,10 +161,10 @@
inherit shell;
inherit devEnv;
packages = [
- ruby_3_4
- rubyPackages_3_4.rake
- rubyPackages_3_4.sqlite3
- rubyPackages_3_4.thor
+ ruby
+ rubyPackages.rake
+ rubyPackages.sqlite3
+ rubyPackages.thor
sqlite
graphicsmagick
zip
@@ -181,10 +181,10 @@
inherit shell;
inherit devEnv;
packages = [
- ruby_3_4
- rubyPackages_3_4.rake
- rubyPackages_3_4.sqlite3
- rubyPackages_3_4.thor
+ ruby
+ rubyPackages.rake
+ rubyPackages.sqlite3
+ rubyPackages.thor
sqlite
graphicsmagick
perl538Packages.Po4a