aboutsummaryrefslogtreecommitdiffhomepage
path: root/devenv.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2023-04-10 16:36:59 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2023-04-10 17:48:06 -0400
commit74f78edc9dd6590e1c01e27b39083ea838ecb976 (patch)
tree75ac9109f0d69e73be14c00d87aebe1bdfcb961a /devenv.nix
parentnix flake & build, temp. remove gdc (diff)
nix org cleaning
- including run of alejandra nix formater
Diffstat (limited to 'devenv.nix')
-rw-r--r--devenv.nix85
1 files changed, 44 insertions, 41 deletions
diff --git a/devenv.nix b/devenv.nix
index 6984ace..894b0ec 100644
--- a/devenv.nix
+++ b/devenv.nix
@@ -1,42 +1,45 @@
-{ pkgs ? import <nixpkgs> { }, name ? "user-env" }:
+{
+ pkgs ? import <nixpkgs> {},
+ name ? "user-env",
+}:
with pkgs;
-buildEnv {
- inherit name;
- extraOutputsToInstall = [ "out" "man" "lib" ]; # to get all needed symlinks
- paths = [
- # ❯❯❯ nix_related
- #nix # if not on NixOS, this is needed
- direnv
- #cachix
- nixVersions.unstable #nixFlakes
- nix-prefetch-git
- validatePkgConfig
- nix-output-monitor
- nix-tree
- jq
- git
- gnumake
- ps
- # ❯❯❯ d_build_related
- # ❯❯ package manager
- dub
- # ❯❯ compiler
- dmd
- ldc
- # ❯❯❯ sqlite search related
- sqlite
- # this will create a script that will rebuild and upgrade your setup; using shell script syntax
- (writeScriptBin "nix-rebuild" ''
- #!${stdenv.shell}
- cd <path-to-flake> || exit 1
- nix flake update
- nix profile upgrade '.*'
- '')
- # puts in your root the nixpkgs version
- (writeTextFile {
- name = "nixpkgs-version";
- destination = "/nixpkgs-version";
- text = lib.version;
- })
- ];
-}
+ buildEnv {
+ inherit name;
+ extraOutputsToInstall = ["out" "man" "lib"]; # to get all needed symlinks
+ paths = [
+ # ❯❯❯ nix_related
+ #nix # if not on NixOS, this is needed
+ direnv
+ nixVersions.unstable #nixFlakes
+ nix-prefetch-git
+ validatePkgConfig
+ nix-output-monitor
+ nix-tree
+ jq
+ alejandra
+ git
+ # ❯❯❯ dev
+ gnumake
+ ps
+ # ❯❯❯ d_build_related
+ # ❯❯ package manager
+ dub
+ # ❯❯ compiler
+ ldc
+ # ❯❯❯ sqlite search related
+ sqlite
+ # this will create a script that will rebuild and upgrade your setup; using shell script syntax
+ (writeScriptBin "nix-rebuild" ''
+ #!${stdenv.shell}
+ #cd <path-to-flake> || exit 1
+ nix flake update
+ nix profile upgrade '.*'
+ '')
+ # puts in your root the nixpkgs version
+ (writeTextFile {
+ name = "nixpkgs-version";
+ destination = "/nixpkgs-version";
+ text = lib.version;
+ })
+ ];
+ }