aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2024-03-11 21:06:25 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2024-03-11 21:07:28 -0400
commit1aed76229222550727e7119bbca3cde59a043f9e (patch)
tree11e7b61079a467169750127565da1d7af66417fb /flake.nix
parentupdates incl. ldc-1.35.0, direnv-2.4.0 (diff)
package & nix update (sync with sisu spine)
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix17
1 files changed, 7 insertions, 10 deletions
diff --git a/flake.nix b/flake.nix
index 08c50c8..c5bbcc1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -19,9 +19,9 @@
spine,
d-overlay,
} @ inputs: let
- version = "0.12.0";
- shell = ./shell.nix; # ./default.nix;
- devEnv = ./.envrc; # ./shell.nix; # ./default.nix;
+ version = "0.14.0";
+ shell = ./shell.nix;
+ devEnv = ./nixDevEnv.sh;
supportedSystems = ["x86_64-linux"]; # [ "x86_64-linux" "x86_64-darwin" "aarch64-linux" "aarch64-darwin" ];
forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
nixpkgsFor = forAllSystems (system: import nixpkgs {inherit system;}); # nixpkgs instantiated for supported system types
@@ -30,11 +30,10 @@
pkgs = nixpkgsFor.${system};
in {
default = spine.packages.${system}.default;
- spine-overlay-ldc = spine.packages.${system}.spine-overlay-ldc;
+ spine-nixpkgs-dmd = spine.packages.${system}.spine-nixpkgs-dmd;
+ spine-overlay-dmd = spine.packages.${system}.spine-overlay-dmd;
spine-nixpkgs-ldc = spine.packages.${system}.spine-nixpkgs-ldc;
- #spine-overlay-dmd = spine.packages.${system}.spine-overlay-dmd;
- #spine-overlay-ldc = spine.packages.${system}.spine-overlay-ldc;
- #spine-overlay-gdc = spine.packages.${system}.spine-overlay-gdc;
+ spine-overlay-ldc = spine.packages.${system}.spine-overlay-ldc;
#vendorSha256 = "sha256-0Q00000000000000000000000000000000000000000=";
});
apps = forAllSystems (system: {
@@ -56,8 +55,6 @@
name = "spine base dev shell";
inherit shell;
inherit devEnv;
- #buildInputs = [ sqlite ];
- #nativeBuildInputs = [ dub dmd ldc gdc gnumake ];
packages = [
ldc
#dmd
@@ -92,6 +89,7 @@
epr
sigil
calibre #(suite includes: ebook-viewer)
+ koreader
foliate
];
inherit shellHook;
@@ -118,7 +116,6 @@
#dmd
dub
gnumake
- sqlite
source-sans-pro
source-serif-pro
source-code-pro