aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2023-02-10 10:21:30 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2023-02-15 14:07:48 -0500
commit847bb22acddd1ac5beb1d5b597eb43ff673f0fc4 (patch)
tree931cf0d9904c6e7f920d0cc2a55b670365eb89b3 /flake.nix
parentnix flake & build, devShells etc. (diff)
nix .envrc, add ./result/bin path, flake.nix minor
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index c110f56..00bcaad 100644
--- a/flake.nix
+++ b/flake.nix
@@ -56,7 +56,7 @@
'';
in with pkgs; {
devShell = mkShell rec {
- name = "spine dev shell default";
+ name = "spine base dev shell";
inherit shell;
inherit devEnv;
#buildInputs = [ sqlite ];
@@ -72,8 +72,8 @@
inherit shell;
inherit devEnv;
packages = [
- sqlite
dub dmd ldc gdc gnumake
+ sqlite
libxml2
html-tidy
xmlstarlet
@@ -96,8 +96,8 @@
inherit shell;
inherit devEnv;
packages = [
- sqlite
dub dmd ldc gdc gnumake
+ sqlite
];
inherit shellHook;
};
@@ -106,8 +106,8 @@
inherit shell;
inherit devEnv;
packages = [
- sqlite
dub dmd ldc gdc gnumake
+ sqlite
source-sans-pro
source-serif-pro
source-code-pro
@@ -120,8 +120,8 @@
inherit shell;
inherit devEnv;
packages = [
- sqlite
dub dmd ldc gdc gnumake
+ sqlite
];
inherit shellHook;
};
@@ -129,12 +129,13 @@
inherit shell;
inherit devEnv;
packages = [
- sqlite
dub dmd ldc gdc gnumake
+ sqlite
perl534Packages.Po4a
];
inherit shellHook;
};
+ default = import ./shell.nix { inherit pkgs; };
});
};
}