aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2023-02-21 18:56:06 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2023-02-24 22:19:43 -0500
commit89077febca032ff9990a163a8cdb7f3bc62c3954 (patch)
treec309f7a9d06cab67c4bedf4a39da82baabd3d730 /shell.nix
parentnix .envrc, add ./result/bin path, flake.nix minor (diff)
nix flake & build, temp. remove gdc
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix82
1 files changed, 25 insertions, 57 deletions
diff --git a/shell.nix b/shell.nix
index 7007e99..92dd067 100755
--- a/shell.nix
+++ b/shell.nix
@@ -4,7 +4,7 @@
with pkgs;
mkShell {
buildInputs = [
- ### nix_related
+ # ❯❯❯ nix_related
# direnv
# nixVersions.unstable #nixFlakes
# nix-prefetch-git
@@ -12,26 +12,26 @@ mkShell {
# nix-tree jq nix-output-monitor
# git
# ps
- ### d_build_related
- ### package manager
+ # ❯❯❯ d_build_related
+ # ❯❯ package manager
# dub
- ### compiler
+ # ❯❯ compiler
# ldc
# rund
- ### linker
+ # ❯❯ linker
# #lld
# #mold
- ## builder
+ # ❯❯ builder
# #ninja
# #meson
- ### sqlite search related
- # sqlite
- ### pdf_latex_related
+ # ❯❯❯ sqlite search related
+ #sqlite
+ # ❯❯❯ pdf_latex_related
# source-sans-pro
# source-serif-pro
# source-code-pro
# texlive.combined.scheme-full
- ### xml_and_epub_related
+ # ❯❯❯ xml_and_epub_related
# libxml2
# html-tidy
# xmlstarlet
@@ -41,58 +41,26 @@ mkShell {
# sigil
# calibre #(suite includes: ebook-viewer)
# foliate
- ### i18n translation related
+ # ❯❯❯ i18n translation related
# perl534Packages.Po4a
];
shellHook = ''
- #if [[ -f ".envrc" ]]; then
- # source .envrc
- #fi
- #nix flake update
- #echo ""
- #echo "nix flake metadata:"
- #nix flake metadata
- #echo ""
- #echo "nix flake check:"
- #nix flake check
- #echo ""
- #echo "nix flake show:"
- #nix flake show
- echo "
- nix flake update
- nix flake metadata
- nix flake check
- nix flake show
+ nix flake update
+ nix flake check
+ nix flake show
+ echo '
+ shell.nix echo ❯❯
- nix build or nix develop? (suggestions):
+ ❯❯ nix flake update && nix flake check --show-trace && nix flake show && nix develop ".#devShell" -c zsh
- - nix build
- nix build .#default --print-build-logs
- nix build .#default-tarball --print-build-logs
- nix build .#default-markup-samples --print-build-logs
- nix build --print-build-logs
- nix build .#default --print-build-logs |& nom
+ ❯❯ nix develop
+ ❯❯ nix develop -c zsh
- - nix run
- nix run .#default --print-build-logs
- nix run default.nix --print-build-logs
-
- - nix shell
- nix shell .#default --print-build-logs --command spine -v
-
- - nix develop
- nix develop --build .#default --print-build-logs
- nix develop --build -f derivation.nix -I .envrc --print-build-logs
- nix develop ; eval \$buildPhase
-
- nix-build |& nom
-
- spine -v
-
- nix-instantiate | nix show-derivation | jq
- nix-build . --no-out-link | xargs -o nix-tree
- nix-tree --derivation .#default
-
- "
+ ❯❯ nix build
+ ❯❯ nix build ".#default" --print-build-logs
+ ❯❯ nix build ".#spine-dmd" --print-build-logs |& nom
+ ❯❯ nix build ".#spine-ldc" --print-build-logs |& nom
+ ❯❯ nix build ".#spine-gdc" --print-build-logs |& nom
+ '
'';
}