aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2024-12-03 17:58:47 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2024-12-03 18:47:04 -0500
commit03ab3dbfde3a65dfa17a81b5506cc61e11c2d61d (patch)
tree5c1f46d6bca1f73da22f9ea2245eee5fe26e7df5 /flake.nix
parentnix build houskeeping, version updates, incl. dmd & dub (diff)
nix build flake.nix fix
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 866f7fb..f6faed7 100644
--- a/flake.nix
+++ b/flake.nix
@@ -89,8 +89,8 @@
src = self;
inherit shell;
inherit devEnv;
- buildInputs = with pkgs-ovl; [sqlite];
- nativeBuildInputs = with pkgs-ovl; [dub dmd gnumake];
+ buildInputs = with pkgs-nix; [sqlite];
+ nativeBuildInputs = with pkgs-nix; [dub dmd gnumake];
buildPhase = ''
runHook preBuild
buildCMD="dub run --cache=local --compiler=$(type -P dmd) --build=dmd --combined --skip-registry=all"
@@ -113,7 +113,7 @@
inherit shell;
inherit devEnv;
buildInputs = with pkgs-nix; [sqlite];
- nativeBuildInputs = with pkgs-ovl; [dub ldc gnumake];
+ nativeBuildInputs = with pkgs-nix; [dub ldc gnumake];
buildPhase = ''
runHook preBuild
buildCMD="dub run --cache=local --compiler=$(type -P ldmd2) --build=ldmd2 --combined --skip-registry=all"