aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2023-07-08 15:54:02 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2023-07-09 20:48:50 -0400
commit12c4f6a9467d4f0809f51dafd8c1abf0bd98ae0d (patch)
treeed5d77fc6eac60de7cdfbac5cad7746310085ae3 /flake.nix
parentocda, minor, tidy earlier work (diff)
flake nix build dub, set HOME, dub >= 1.31.0 fix
- fixes dub >= 1.31.0 build failure, attempted to build in /homeless-shelter
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 0ac58cf..f784f98 100644
--- a/flake.nix
+++ b/flake.nix
@@ -57,6 +57,9 @@
inherit devEnv;
buildInputs = [sqlite];
nativeBuildInputs = [dub ldc gnumake]; # [ dub dmd ]; [ dub ldc ]; [ dub gdc ];
+ preBuild = ''
+ export HOME=$(pwd)
+ '';
buildPhase = ''
runHook preBuild
for DC_ in dmd ldmd2 ldc2 gdc gdmd; do
@@ -83,6 +86,9 @@
inherit devEnv;
buildInputs = [sqlite];
nativeBuildInputs = [dub dmd gnumake];
+ preBuild = ''
+ export HOME=$(pwd)
+ '';
buildPhase = ''
runHook preBuild
dub build --cache=local --compiler=$(type -P dmd) --build=dmd --combined --skip-registry=all
@@ -102,6 +108,9 @@
inherit devEnv;
buildInputs = [sqlite];
nativeBuildInputs = [dub ldc gnumake];
+ preBuild = ''
+ export HOME=$(pwd)
+ '';
buildPhase = ''
runHook preBuild
dub build --cache=local --compiler=$(type -P ldc2) --build=ldc2 --combined --skip-registry=all
@@ -121,6 +130,9 @@
inherit devEnv;
buildInputs = with pkgs; [sqlite];
nativeBuildInputs = with pkgs; [dub ldc gnumake];
+ preBuild = ''
+ export HOME=$(pwd)
+ '';
buildPhase = ''
runHook preBuild
dub build --cache=local --compiler=$(type -P ldc2) --build=ldc2 --combined --skip-registry=all