aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-01-02 14:06:16 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2021-01-23 17:01:15 -0500
commit4437c10fad8925d6322c83bf1553daa9a36ceb31 (patch)
tree6d5a85e7d5da7d41320a9773bb8830ef4908e3df /flake.nix
parentnix shebangs, consider (diff)
nix, work on build
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..a392048
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,37 @@
+{
+ description = "a sisu like document parser";
+ inputs = {
+ flake-utils.url = "github:numtide/flake-utils";
+ nixpkgs.url = "/nixpkgs-ra/nixpkgs/.gitworktree/ra/nixpkgs";
+ # pkgs /nixpkgs-ra/nixpkgs/.gitworktree/ra/nixpkgs {}
+ #spine.url = "/grotto-ra/repo/git.repo/projects/project-spine/doc-reform";
+ #spine.url = "./.";
+ d2sqlite3 = {
+ url = "github:dlang-community/d2sqlite3";
+ flake = false;
+ };
+ tinyendian = {
+ url = "github:kiith-sa/tinyendian";
+ flake = false;
+ };
+ dyaml = {
+ url = "github:dlang-community/D-YAML";
+ flake = false;
+ };
+ imageformats = {
+ url = "github:lgvz/imageformats";
+ flake = false;
+ };
+ dub2nix-src = {
+ url = "github:lionello/dub2nix";
+ flake = false;
+ };
+ };
+ outputs = { self, nixpkgs, flake-utils }:
+ flake-utils.lib.simpleFlake {
+ #flake-utils.lib.spine {
+ inherit self nixpkgs;
+ name = "spine";
+ #shell = ./shell.nix;
+ };
+}