aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2024-05-17 22:48:20 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2024-05-17 23:42:07 -0400
commit594122acc6ee5766c21098591a7998c76ff80bf2 (patch)
tree5c68cd30667fc6e8642576709795aac533bfff7b /flake.nix
parentnix dlang overlay ldc-1.38.0 (diff)
nix flake and envrc-nix minor
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 93752a5..9755571 100644
--- a/flake.nix
+++ b/flake.nix
@@ -205,6 +205,8 @@
pkgs-nix = nixpkgsFor.${system};
shellHook = ''
export Date=`date "+%Y%m%d"`
+ ## set local values in .envrc-local (or here if you must)
+ echo " ❯❯ ./result/bin/spine -v --source --pod --epub --html --html-link-pdf --html-link-curate --html-link-markup --curate --output=./OUTPUT_TEST_sisudocSpine ../sisu-spine-samples/markup/pod/*";
'';
in
with pkgs-nix; {
@@ -307,6 +309,13 @@
dub
gnumake
sqlite
+ # ❯❯ text-mode web browsers
+ elinks
+ links2
+ lynx
+ w3m
+ # ❯❯ light graphical
+ #dillo
];
inherit shellHook;
};
@@ -319,7 +328,6 @@
#dmd
dub
gnumake
- sqlite
source-sans-pro
source-serif-pro
source-code-pro