aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2024-03-20 10:48:45 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2024-03-20 10:48:45 -0400
commite7c4b9ea5bc2cd2d0d28c0daeaf2e7271b317368 (patch)
tree655a74b3ce01ef8629c6680d9eed55363bf77f4a /flake.nix
parentmark modules as @safe: (& identify what is not) (diff)
flake.nix cosmetic minor
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/flake.nix b/flake.nix
index b1be7ea..a1d7495 100644
--- a/flake.nix
+++ b/flake.nix
@@ -9,8 +9,8 @@
} @ inputs: let
pname = "spine";
version = "0.14.0";
- shell = ./shell.nix; # ./default.nix;
- devEnv = ./nixDevEnv.sh; # ./shell.nix; # ./default.nix; # ./.envrc;
+ shell = ./shell.nix;
+ devEnv = ./nixDevEnv.sh;
supportedSystems = ["x86_64-linux"]; # [ "x86_64-linux" "x86_64-darwin" "aarch64-linux" "aarch64-darwin" ];
forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
nixpkgsFor = forAllSystems (system: import nixpkgs {inherit system;}); # nixpkgs instantiated for supported system types
@@ -22,8 +22,8 @@
localOverlay = (final: prev: {
ldc = prev.callPackage ./nix-overlays/ldc { };
dmd = prev.callPackage ./nix-overlays/dmd { };
- dub = prev.callPackage ./nix-overlays/dub { }; # -> ?
- #gdc = prev.callPackage ./nix-overlays/gdc { }; # empty
+ dub = prev.callPackage ./nix-overlays/dub { };
+ #gdc = prev.callPackage ./nix-overlays/gdc { };
});
pkgsForSystem = system: import nixpkgs {
overlays = [