aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2019-10-05 20:45:42 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2019-10-17 19:07:20 -0400
commit1083951efc4f8ddbf8de65907cc5aee2ac6be2ed (patch)
tree0b3f2dd576301a0d15d23c8a0ccc1afff1e86717 /meson.build
parent--show-{config,make,metadata,summary} (diff)
0.8.1 conf, make, meta: yaml only (toml removed)doc-reform_v0.8.1
- yaml only: config, make & headers (yaml is converted directly to struct) - toml removed: preemptively remove confusion of having multiple config formats (toml was converted to json & json to struct) - json removed (intermediate representation): takes out intermediate conversion to json which could be attractive to have if there are multiple formats
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 0 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 21b34e1..c2a3859 100644
--- a/meson.build
+++ b/meson.build
@@ -8,7 +8,6 @@ doc_reform_sources = [
'src/doc_reform/conf/compile_time_info.d',
'src/doc_reform/meta/conf_make_meta_json.d',
'src/doc_reform/meta/conf_make_meta_structs.d',
- 'src/doc_reform/meta/conf_make_meta_toml.d',
'src/doc_reform/meta/conf_make_meta_yaml.d',
'src/doc_reform/meta/defaults.d',
'src/doc_reform/meta/doc_debugs.d',
@@ -46,7 +45,6 @@ sources_dir = include_directories('src/')
# Dependencies
dep_d2sqlite3 = dependency('d2sqlite3', version: '>= 0.16.2', fallback: ['d2sqlite3', 'd2sqlite3_dep'])
dep_imageformats = dependency('imageformats-d', version: '>= 7.0.0', fallback: ['imageformats-d', 'imageformats_dep'])
-dep_toml = dependency('toml-d', version: '>= 1.0.0', fallback: ['toml-d', 'toml_dep'])
# executable
doc_reform_exe = executable('rad',
[doc_reform_sources],
@@ -55,7 +53,6 @@ doc_reform_exe = executable('rad',
dependencies : [
dep_d2sqlite3,
dep_imageformats,
- dep_toml
],
install : true
)