aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2020-03-06 15:11:55 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2020-03-14 15:17:44 -0400
commit2c95e88e40ff3cf021eb9e2e0b7a87f68d5e1e37 (patch)
tree85693bb7813a51f9af9925b08508280183962906 /meson.build
parentmeson build (subproject issue with imageformats >= 7.0.1) (diff)
meson using dubdoc-reform_v0.9.2
- the good - works - project looks pretty clean - the bad - subprojects built externally - not suitable for debian packaging
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 5 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index b483de4..c8300ff 100644
--- a/meson.build
+++ b/meson.build
@@ -49,15 +49,17 @@ spine_sources = [
source_root = meson.source_root()
sources_dir = include_directories('src/')
# Dependencies
-dep_dyaml = dependency('dyaml', version: '>= 0.8.0', fallback: ['dyaml', 'dyaml_dep'])
-dep_d2sqlite3 = dependency('d2sqlite3', version: '>= 0.18.3', fallback: ['d2sqlite3', 'd2sqlite3_dep'])
-dep_imageformats = dependency('imageformats', version: '>= 7.0.2', fallback: ['imageformats', 'imageformats_dep'])
+dep_tinyendian = dependency('tinyendian', version: '>= 0.2.0', fallback: ['tinyendian', 'tinyendian_dep'], method: 'dub')
+dep_dyaml = dependency('dyaml', version: '>= 0.8.0', fallback: ['dyaml', 'dyaml_dep'], method: 'dub')
+dep_d2sqlite3 = dependency('d2sqlite3', version: '>= 0.18.3', fallback: ['d2sqlite3', 'd2sqlite3_dep'], method: 'dub')
+dep_imageformats = dependency('imageformats', version: '>= 7.0.2', fallback: ['imageformats', 'imageformats_dep'], method: 'dub')
# Executable
spine_exe = executable('spine',
[spine_sources],
include_directories : [sources_dir],
d_import_dirs: [include_directories('views')],
dependencies : [
+ dep_tinyendian,
dep_dyaml,
dep_d2sqlite3,
dep_imageformats,