aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorRalph Amissah <ralph@amissah.com>2020-02-07 10:52:16 -0500
committerRalph Amissah <ralph@amissah.com>2020-03-06 15:13:53 -0500
commit503412b02356cd0dd92f0fc0900f48eab3afce24 (patch)
tree0e8ee05bcb814db5d414386c42fd9cd64804d892 /meson.build
parentlatex outputs (various paper sizes & orientation) (diff)
meson build
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 11 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 05be115..41d6db3 100644
--- a/meson.build
+++ b/meson.build
@@ -1,8 +1,11 @@
project('spine', 'd',
license: 'AGPL3',
- version: '0.26.5',
+ version: '0.9.2',
meson_version: '>=0.46'
)
+#if meson.get_compiler('d').get_id() == 'gcc'
+# error('spine cannot be compiled with GDC at time. Sorry.')
+#endif
spine_sources = [
'src/doc_reform/spine.d',
'src/doc_reform/conf/compile_time_info.d',
@@ -15,6 +18,7 @@ spine_sources = [
'src/doc_reform/io_out/html.d',
'src/doc_reform/io_out/hub.d',
'src/doc_reform/io_out/latex.d',
+ 'src/doc_reform/io_out/metadata.d',
'src/doc_reform/io_out/odt.d',
'src/doc_reform/io_out/package.d',
'src/doc_reform/io_out/paths_output.d',
@@ -45,14 +49,16 @@ spine_sources = [
source_root = meson.source_root()
sources_dir = include_directories('src/')
# Dependencies
-dep_d2sqlite3 = dependency('d2sqlite3', version: '>= 0.16.2', fallback: ['d2sqlite3', 'd2sqlite3_dep'])
-dep_imageformats = dependency('imageformats-d', version: '>= 7.0.0', fallback: ['imageformats-d', 'imageformats_dep'])
-# executable
-spine_exe = executable('dr',
+dep_dyaml = dependency('dyaml', version: '>= 0.8.0', fallback: ['dyaml', 'dyaml_dep'])
+dep_d2sqlite3 = dependency('d2sqlite3', version: '>= 0.18.3', fallback: ['d2sqlite3', 'd2sqlite3_dep'])
+dep_imageformats = dependency('imageformats', version: '>= 7.0.0', fallback: ['imageformats', 'imageformats_dep'])
+# Executable
+spine_exe = executable('spine',
[spine_sources],
include_directories : [sources_dir],
d_import_dirs: [include_directories('views')],
dependencies : [
+ dep_dyaml,
dep_d2sqlite3,
dep_imageformats,
],