aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2020-05-12 17:11:53 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2020-05-21 11:51:58 -0400
commit6a5c473653f03aee818d835b53ca30b62a3be6c7 (patch)
treedfec2ef22a834f5c2a7003a4884bb7c7a8288609 /meson.build
parentdoc abstraction, code & org whitespace, cosmetic (diff)
meson using subproject directory, not dub directly
- will not work until meson.build files in - d2sqlite3 - imageformats (request adding upstream) - dyaml and its dependency tinyendian already provide their meson.build (should probably revert to meson dub until resolved) - based on 1468425 meson build (no issue now with imagefomats using 7.0.2)
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build16
1 files changed, 8 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 74ad756..76e0782 100644
--- a/meson.build
+++ b/meson.build
@@ -6,7 +6,7 @@ project('spine', 'd',
#if meson.get_compiler('d').get_id() == 'gcc'
# error('spine cannot be compiled with GDC at time. Sorry.')
#endif
-spine_sources = [
+spine_src = [
'src/doc_reform/spine.d',
'src/doc_reform/conf/compile_time_info.d',
'src/doc_reform/io_in/paths_source.d',
@@ -48,16 +48,16 @@ spine_sources = [
'src/doc_reform/share/defaults.d',
]
source_root = meson.source_root()
-sources_dir = include_directories('src/')
+src_dir = include_directories('src/', 'subprojects/')
# Dependencies
-dep_tinyendian = dependency('tinyendian', version: '>= 0.2.0', fallback: ['tinyendian', 'tinyendian_dep'], method: 'dub')
-dep_dyaml = dependency('dyaml', version: '>= 0.8.0', fallback: ['dyaml', 'dyaml_dep'], method: 'dub')
-dep_d2sqlite3 = dependency('d2sqlite3', version: '>= 0.18.3', fallback: ['d2sqlite3', 'd2sqlite3_dep'], method: 'dub')
-dep_imageformats = dependency('imageformats', version: '>= 7.0.2', fallback: ['imageformats', 'imageformats_dep'], method: 'dub')
+dep_tinyendian = dependency('tinyendian', version: '>= 0.2.0', fallback: ['tinyendian', 'tinyendian_dep'])
+dep_dyaml = dependency('dyaml', version: '>= 0.8.0', fallback: ['dyaml', 'dyaml_dep'])
+dep_d2sqlite3 = dependency('d2sqlite3', version: '>= 0.18.3', fallback: ['d2sqlite3', 'd2sqlite3_dep'])
+dep_imageformats = dependency('imageformats', version: '>= 7.0.2', fallback: ['imageformats', 'imageformats_dep'])
# Executable
spine_exe = executable('spine',
- [spine_sources],
- include_directories : [sources_dir],
+ [spine_src],
+ include_directories : [src_dir],
d_import_dirs: [include_directories('views')],
dependencies : [
dep_tinyendian,