aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2020-05-21 11:28:40 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2020-06-03 20:20:16 -0400
commita0fa5da681bf2f6c5e50435f29583a490253f995 (patch)
tree151b37496c8b44716d24d4483df5eb80f18a747f /meson.build
parentmakefile dub build flags (diff)
meson revert to direct use of dub
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 5 insertions, 5 deletions
diff --git a/meson.build b/meson.build
index 76e0782..cc644a6 100644
--- a/meson.build
+++ b/meson.build
@@ -48,12 +48,12 @@ spine_src = [
'src/doc_reform/share/defaults.d',
]
source_root = meson.source_root()
-src_dir = include_directories('src/', 'subprojects/')
+src_dir = include_directories('src/')
# Dependencies
-dep_tinyendian = dependency('tinyendian', version: '>= 0.2.0', fallback: ['tinyendian', 'tinyendian_dep'])
-dep_dyaml = dependency('dyaml', version: '>= 0.8.0', fallback: ['dyaml', 'dyaml_dep'])
-dep_d2sqlite3 = dependency('d2sqlite3', version: '>= 0.18.3', fallback: ['d2sqlite3', 'd2sqlite3_dep'])
-dep_imageformats = dependency('imageformats', version: '>= 7.0.2', fallback: ['imageformats', 'imageformats_dep'])
+dep_tinyendian = dependency('tinyendian', version: '>= 0.2.0', fallback: ['tinyendian', 'tinyendian_dep'], method: 'dub')
+dep_dyaml = dependency('dyaml', version: '>= 0.8.0', fallback: ['dyaml', 'dyaml_dep'], method: 'dub')
+dep_d2sqlite3 = dependency('d2sqlite3', version: '>= 0.18.3', fallback: ['d2sqlite3', 'd2sqlite3_dep'], method: 'dub')
+dep_imageformats = dependency('imageformats', version: '>= 7.0.2', fallback: ['imageformats', 'imageformats_dep'], method: 'dub')
# Executable
spine_exe = executable('spine',
[spine_src],