aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2020-09-26 14:44:34 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2020-10-19 13:41:43 -0400
commit124782c1745c4dbfd3dc84f5e50e0214899e39f7 (patch)
tree7258689c84e5cb4e199685cafb0533374962f5f0 /shell.nix
parentshell.nix (diff)
nixify step
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix32
1 files changed, 15 insertions, 17 deletions
diff --git a/shell.nix b/shell.nix
index 5b97ffe..b226cd3 100644
--- a/shell.nix
+++ b/shell.nix
@@ -1,19 +1,17 @@
-{ pkgs ? import <nixpkgs> {} }:
-
-with pkgs;
-
-mkShell {
- buildInputs = with pkgs; [
- ninja dub
- meson git
- ldc #ldc dmd gdc
- sqlite
- validatePkgConfig
- #gnumake gcc gdc cmake
- #dzen2
+{ pkgs ? import <nixpkgs> {
+ overlays = [
+ (import ./nixDevEnv/overlays/ldcVersion.nix)
+ (import ./nixDevEnv/overlays/dmdVersion.nix)
+ ]; }
+}:
+ pkgs.mkShell {
+ buildInputs = with pkgs; [
+ dub
+ ninja
+ #meson
+ dmd
+ ldc
+ sqlite
+ validatePkgConfig
];
- shellHook = ''
- echo `ldc2 --version`
- '';
- COMPILER = "ldc2";
}