aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-12-23 10:06:47 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2021-12-23 11:12:53 -0500
commit168e45c3b73ed705ad665395ec1ef5ffc4dc3a6b (patch)
treebcce2f043de8fb93661fd3edfb53f1ab1eecf893 /shell.nix
parentmetaverse, xml dom close eof (diff)
nix setup related but messy
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix25
1 files changed, 17 insertions, 8 deletions
diff --git a/shell.nix b/shell.nix
index 0ac55ea..fa4c3c4 100755
--- a/shell.nix
+++ b/shell.nix
@@ -3,25 +3,32 @@
with pkgs;
mkShell {
buildInputs = [
- # nix_related
+ ### nix_related
nixFlakes
nix-prefetch-git
validatePkgConfig
jq
git
- # d_build_related
- rund
+ ### d_build_related
+ ## package manager
dub
+ ## compiler
ldc
+ rund
+ ## linker
+ #lld
+ #mold
+ ## builder
+ #ninja
#meson
- # search related
+ ### sqlite search related
sqlite
- # # pdf_latex_related
+ # ### pdf_latex_related
# source-sans-pro
# source-serif-pro
# source-code-pro
# texlive.combined.scheme-full
- # # xml_and_epub_related
+ # ### xml_and_epub_related
# libxml2
# html-tidy
# xmlstarlet
@@ -29,9 +36,11 @@ mkShell {
# ebook_tools
# epr
# sigil
- # calibre # (ebook-viewer)
+ # calibre #(suite includes: ebook-viewer)
# foliate
- # candy
+ # ### i18n translation related
+ # perl534Packages.Po4a
+ ### candy
starship
];
shellHook = ''