aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2024-03-08 20:52:36 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2024-03-10 15:39:53 -0400
commit2a874332f535d13ae0dbe3ced6cd5cd55ae74f93 (patch)
treecccd3cd96d996dc6e19213ad5e44a574729d915e /shell.nix
parentdmd & ldc upkeep (dmd at 2.106.1) (diff)
nix flake & env upkeep
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/shell.nix b/shell.nix
index d90aa6c..4093de6 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,7 +1,7 @@
#!/usr/bin/env -S nix-shell --pure
#!nix-shell -i bash
-{pkgs ? import <nixpkgs> {}}:
-with pkgs;
+{pkgs-nix ? import <nixpkgs> {}}:
+with pkgs-nix;
mkShell {
buildInputs = [
# ❯❯❯ nix_related
@@ -13,16 +13,17 @@ with pkgs;
nix-output-monitor
nix-tree
jq #gx
- alejandra
+ #alejandra
git
# ❯❯❯ dev
gnumake
ps
# ❯❯❯ d_build_related
# ❯❯ package manager
- dub
+ #dub
# ❯❯ compiler
- ldc
+ #dmd
+ #ldc
#rund
# ❯❯ linker
#lld
@@ -31,7 +32,7 @@ with pkgs;
#ninja
#meson
# ❯❯❯ sqlite search related
- sqlite
+ #sqlite
# ❯❯❯ pdf_latex_related
# source-sans-pro
# source-serif-pro