aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2022-12-08 20:28:06 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2022-12-23 18:17:24 -0500
commit684091e7e5c958561d4c0d7bd6c77f9a5efa80c3 (patch)
tree7b1d104632da28a7156b6d8446259389bac06b60 /shell.nix
parentspine-search-cgi separate commits, remove sundry (diff)
gitignore & things nix
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/shell.nix b/shell.nix
index d745b40..8a19e80 100755
--- a/shell.nix
+++ b/shell.nix
@@ -4,16 +4,14 @@
with pkgs;
mkShell {
buildInputs = [
- ### nix_related
direnv
nixVersions.unstable #nixFlakes
nix-prefetch-git
validatePkgConfig
- nix-tree jq
+ nix-tree jq nix-output-monitor
git
ps
### d_build_related
- ## package manager
dub
## compiler
ldc
@@ -60,7 +58,6 @@ mkShell {
echo ""
echo "nix flake show:"
nix flake show
- echo ""
echo "
nix flake update
nix flake metadata
@@ -70,18 +67,23 @@ mkShell {
nix build or nix develop? (suggestions):
- nix build
- nix build .#spine --print-build-logs
+ nix build .#default --print-build-logs
nix build --print-build-logs
+ nix build .#default --print-build-logs |& nom
- nix run
nix run .#spine --print-build-logs
nix run default.nix --print-build-logs
+
- nix shell
nix shell --print-build-logs --command spine -v
+
- nix develop
- nix develop --build .#spine --print-build-logs
+ nix develop --build .#default --print-build-logs
nix develop --build -f derivation.nix -I .envrc --print-build-logs
- nix develop ; eval $buildPhase
+ nix develop ; eval \$buildPhase
+
+ nix-build |& nom
spine -v