aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2023-01-26 21:16:47 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2023-02-10 10:42:28 -0500
commit970eea0a508d3a0a1f8c9e01c3667ceedaa5fb0f (patch)
tree7967c4648c8e58084d15c195a5c1ef189c139be6 /shell.nix
parentnix & build housekeeping (diff)
nix flake & build, devShells etc.
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/shell.nix b/shell.nix
index 8f86997..c7eb24c 100755
--- a/shell.nix
+++ b/shell.nix
@@ -26,12 +26,12 @@ mkShell {
#meson
### sqlite search related
sqlite
- # ### pdf_latex_related
+ ### pdf_latex_related
# source-sans-pro
# source-serif-pro
# source-code-pro
# texlive.combined.scheme-full
- # ### xml_and_epub_related
+ ### xml_and_epub_related
# libxml2
# html-tidy
# xmlstarlet
@@ -41,10 +41,8 @@ mkShell {
# sigil
# calibre #(suite includes: ebook-viewer)
# foliate
- # ### i18n translation related
+ ### i18n translation related
# perl534Packages.Po4a
- ### candy
- #starship
];
shellHook = ''
#if [[ -f ".envrc" ]]; then
@@ -81,7 +79,7 @@ mkShell {
nix shell --print-build-logs --command spine -v
- nix develop
- nix develop --build .#default --print-build-logs
+ nix develop --build .#default --print-build-logs
nix develop --build -f derivation.nix -I .envrc --print-build-logs
nix develop ; eval \$buildPhase