aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-02-04 22:12:27 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2021-02-04 22:25:39 -0500
commitba9da295a0efefc0537d7554b2f4488ae94ece2d (patch)
tree32c2e6d1d6d87c4dd4c322210baedb042be71ecf /shell.nix
parentsome pod samples including default generated and sisu-markup (diff)
shell_spine.nix added
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index 17ccd5b..c2e52a6 100755
--- a/shell.nix
+++ b/shell.nix
@@ -1,4 +1,3 @@
-#!/usr/bin/env -S nix-shell
{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
buildInputs = with pkgs; [
@@ -7,6 +6,9 @@ pkgs.mkShell {
buildPhase = "nix build -f default.nix";
shellHook = ''
echo "built spine @ ./result/bin/spine"
+ if [[ -e ".envrc" ]]; then
+ source .envrc
+ fi
#nix-instantiate | nix show-derivation | jq
'';
}