aboutsummaryrefslogtreecommitdiffhomepage
path: root/spine.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-04-20 19:13:21 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2021-04-20 19:16:39 -0400
commit08e51e75cab75abc20992faed5fd8215d1b48d28 (patch)
treecfc56e49e4f77363d02b22b3f0342ee1cbc27f20 /spine.nix
parentext-dep: d2sqlite3 updated (diff)
spine_build_scaffold: nix related housekeeping
- mkDub.nix (dub2nix) use lib, stdenv.lib deprecated - .envrc stop using lorri - .envrc-local_ set local variables as needed
Diffstat (limited to 'spine.nix')
-rwxr-xr-xspine.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/spine.nix b/spine.nix
index 1d9f352..fa90ad9 100755
--- a/spine.nix
+++ b/spine.nix
@@ -1,6 +1,7 @@
#!/usr/bin/env -S nix-build
{ pkgs ? import <nixpkgs> {},
stdenv ? pkgs.stdenv,
+ lib ? pkgs.lib,
ldc ? null,
dcompiler ? pkgs.ldc,
dub ? pkgs.dub
@@ -9,7 +10,7 @@ assert dcompiler != null;
#with import ./nix/mkDub.nix { inherit pkgs; };
with ( # mkDub.nix
assert dcompiler != null;
- with stdenv;
+ with stdenv lib;
let
# Filter function to remove the .dub package folder from src
filterDub = name: type: let baseName = baseNameOf (toString name); in ! (