aboutsummaryrefslogtreecommitdiffhomepage
path: root/sundry/spine_search_cgi/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-10-07 20:39:57 -0400
committerRalph Amissah <ralph.amissah@gmail.com>2021-11-27 19:40:47 -0500
commite37589f5f5253d81c62f8846dbf721c23fe48d44 (patch)
treef6a92b74b3b82453f7bce68b33647a428d144624 /sundry/spine_search_cgi/shell.nix
parentsqlite related internal naming (diff)
configuration, hierarchy filenames & paths ...
Diffstat (limited to 'sundry/spine_search_cgi/shell.nix')
-rwxr-xr-xsundry/spine_search_cgi/shell.nix38
1 files changed, 18 insertions, 20 deletions
diff --git a/sundry/spine_search_cgi/shell.nix b/sundry/spine_search_cgi/shell.nix
index 5926e62..55ca4ae 100755
--- a/sundry/spine_search_cgi/shell.nix
+++ b/sundry/spine_search_cgi/shell.nix
@@ -1,26 +1,24 @@
#!/usr/bin/env -S nix-shell --pure
{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
- buildInputs = with pkgs; [(
- with pkgs; [
- # nix_related
- nixFlakes
- nix-prefetch-git
- validatePkgConfig
- jq
- git
- # d_build_related
- rund
- dub
- ldc
- #meson
- # search_sqlite_related
- # search related
- sqlite
- # candy
- starship
- ]
- )];
+ buildInputs = with pkgs; [
+ # nix_related
+ nixFlakes
+ nix-prefetch-git
+ validatePkgConfig
+ jq
+ git
+ # d_build_related
+ rund
+ dub
+ ldc
+ #meson
+ # search_sqlite_related
+ # search related
+ sqlite
+ # candy
+ starship
+ ];
shellHook = ''
if [[ -e ".envrc" ]]; then
source .envrc