aboutsummaryrefslogtreecommitdiffhomepage
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build42
1 files changed, 22 insertions, 20 deletions
diff --git a/meson.build b/meson.build
index 97ad4cb..05be115 100644
--- a/meson.build
+++ b/meson.build
@@ -6,6 +6,23 @@ project('spine', 'd',
spine_sources = [
'src/doc_reform/spine.d',
'src/doc_reform/conf/compile_time_info.d',
+ 'src/doc_reform/io_in/paths_source.d',
+ 'src/doc_reform/io_in/read_config_files.d',
+ 'src/doc_reform/io_in/read_source_files.d',
+ 'src/doc_reform/io_out/create_zip_file.d',
+ 'src/doc_reform/io_out/defaults.d',
+ 'src/doc_reform/io_out/epub3.d',
+ 'src/doc_reform/io_out/html.d',
+ 'src/doc_reform/io_out/hub.d',
+ 'src/doc_reform/io_out/latex.d',
+ 'src/doc_reform/io_out/odt.d',
+ 'src/doc_reform/io_out/package.d',
+ 'src/doc_reform/io_out/paths_output.d',
+ 'src/doc_reform/io_out/rgx.d',
+ 'src/doc_reform/io_out/source_pod.d',
+ 'src/doc_reform/io_out/sqlite.d',
+ 'src/doc_reform/io_out/xmls_css.d',
+ 'src/doc_reform/io_out/xmls.d',
'src/doc_reform/meta/conf_make_meta_json.d',
'src/doc_reform/meta/conf_make_meta_structs.d',
'src/doc_reform/meta/conf_make_meta_yaml.d',
@@ -16,29 +33,14 @@ spine_sources = [
'src/doc_reform/meta/metadoc_harvest.d',
'src/doc_reform/meta/metadoc_harvests_authors.d',
'src/doc_reform/meta/metadoc_harvests_topics.d',
- 'src/doc_reform/meta/metadochead.d',
+ 'src/doc_reform/meta/metadoc_object_setter.d',
+ 'src/doc_reform/meta/metadoc_show_config.d',
+ 'src/doc_reform/meta/metadoc_show_make.d',
+ 'src/doc_reform/meta/metadoc_show_metadata.d',
'src/doc_reform/meta/metadoc_show_summary.d',
- 'src/doc_reform/meta/object_setter.d',
'src/doc_reform/meta/package.d',
'src/doc_reform/meta/rgx.d',
- 'src/doc_reform/output/create_zip_file.d',
- 'src/doc_reform/output/defaults.d',
- 'src/doc_reform/output/epub3.d',
- 'src/doc_reform/output/html.d',
- 'src/doc_reform/output/hub.d',
- 'src/doc_reform/output/latex.d',
- 'src/doc_reform/output/odt.d',
- 'src/doc_reform/output/package.d',
- 'src/doc_reform/output/paths_output.d',
- 'src/doc_reform/output/rgx.d',
- 'src/doc_reform/output/source_pod.d',
- 'src/doc_reform/output/sqlite.d',
- 'src/doc_reform/output/xmls_css.d',
- 'src/doc_reform/output/xmls.d',
'src/doc_reform/share/defaults.d',
- 'src/doc_reform/source/paths_source.d',
- 'src/doc_reform/source/read_config_files.d',
- 'src/doc_reform/source/read_source_files.d',
]
source_root = meson.source_root()
sources_dir = include_directories('src/')
@@ -46,7 +48,7 @@ sources_dir = include_directories('src/')
dep_d2sqlite3 = dependency('d2sqlite3', version: '>= 0.16.2', fallback: ['d2sqlite3', 'd2sqlite3_dep'])
dep_imageformats = dependency('imageformats-d', version: '>= 7.0.0', fallback: ['imageformats-d', 'imageformats_dep'])
# executable
-spine_exe = executable('rad',
+spine_exe = executable('dr',
[spine_sources],
include_directories : [sources_dir],
d_import_dirs: [include_directories('views')],