aboutsummaryrefslogtreecommitdiffhomepage
path: root/nix/pkglst/shell-pkgs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/pkglst/shell-pkgs.nix')
-rw-r--r--nix/pkglst/shell-pkgs.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/nix/pkglst/shell-pkgs.nix b/nix/pkglst/shell-pkgs.nix
new file mode 100644
index 0000000..7587c02
--- /dev/null
+++ b/nix/pkglst/shell-pkgs.nix
@@ -0,0 +1,16 @@
+{ pkgs ? import <nixpkgs> {} }:
+let
+ dub2nix-src = fetchTarball {
+ url = "https://github.com/lionello/dub2nix/archive/master.tar.gz";
+ };
+ dub2nix = (import dub2nix-src) { inherit pkgs; };
+in
+with pkgs; [
+ nixFlakes
+ dub
+ ldc
+ sqlite
+ nix-prefetch-git
+ validatePkgConfig
+ jq
+]