aboutsummaryrefslogtreecommitdiffhomepage
path: root/nix/shell-packages.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nix/shell-packages.nix')
-rw-r--r--nix/shell-packages.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/nix/shell-packages.nix b/nix/shell-packages.nix
new file mode 100644
index 0000000..9e40e24
--- /dev/null
+++ b/nix/shell-packages.nix
@@ -0,0 +1,15 @@
+{ pkgs ? import <nixpkgs> {} }:
+let
+ dub2nix-src = fetchTarball {
+ url = "https://github.com/lionello/dub2nix/archive/master.tar.gz";
+ };
+ dub2nix = (import dub2nix-src) { inherit pkgs; };
+in
+with pkgs; [
+ nixFlakes
+ dub
+ ldc
+ sqlite
+ nix-prefetch-git
+ validatePkgConfig
+]