aboutsummaryrefslogtreecommitdiffhomepage
path: root/nixDevEnv/shells/ldc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixDevEnv/shells/ldc.nix')
-rw-r--r--nixDevEnv/shells/ldc.nix27
1 files changed, 19 insertions, 8 deletions
diff --git a/nixDevEnv/shells/ldc.nix b/nixDevEnv/shells/ldc.nix
index 1900112..31cfcfb 100644
--- a/nixDevEnv/shells/ldc.nix
+++ b/nixDevEnv/shells/ldc.nix
@@ -1,10 +1,21 @@
-{ pkgs ? import <nixpkgs> { overlays = [ (import ../overlays/ldcVersion.nix) ]; } }:
- pkgs.mkShell {
- buildInputs = with pkgs; [
- dub
- ninja
- ldc
- sqlite
- validatePkgConfig
+{ pkgs ? import <nixpkgs> {
+ overlays = [
+ (import ./nixDevEnv/overlays/ldcVersion.nix)
+ ]; }
+}:
+let
+ dub2nix-src = fetchTarball {
+ url = "https://github.com/lionello/dub2nix/archive/master.tar.gz";
+ };
+ dub2nix = (import dub2nix-src) { inherit pkgs; };
+in pkgs.mkShell {
+ buildInputs = with pkgs; [
+ nix
+ dub
+ ldc
+ rdmd
+ sqlite
+ dub2nix
+ nix-prefetch-git
];
}