aboutsummaryrefslogtreecommitdiffhomepage
path: root/src/build_depends/dub2nix/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'src/build_depends/dub2nix/shell.nix')
-rw-r--r--src/build_depends/dub2nix/shell.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/build_depends/dub2nix/shell.nix b/src/build_depends/dub2nix/shell.nix
new file mode 100644
index 0000000..002ff55
--- /dev/null
+++ b/src/build_depends/dub2nix/shell.nix
@@ -0,0 +1,16 @@
+with import <nixpkgs> {};
+
+let
+ pkg = import ./default.nix { inherit pkgs; };
+
+in mkShell {
+
+ buildInputs = [
+ # additional runtime dependencies go here
+ ] ++ pkg.buildInputs ++ pkg.propagatedBuildInputs;
+
+ nativeBuildInputs = [
+ # additional dev dependencies go here
+ ] ++ pkg.nativeBuildInputs;
+
+}