aboutsummaryrefslogtreecommitdiffhomepage
path: root/sundry/spine_search_cgi/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sundry/spine_search_cgi/shell.nix')
-rwxr-xr-xsundry/spine_search_cgi/shell.nix17
1 files changed, 12 insertions, 5 deletions
diff --git a/sundry/spine_search_cgi/shell.nix b/sundry/spine_search_cgi/shell.nix
index 8a73316..7ee5672 100755
--- a/sundry/spine_search_cgi/shell.nix
+++ b/sundry/spine_search_cgi/shell.nix
@@ -3,20 +3,27 @@
with pkgs;
mkShell {
buildInputs = [
- # nix_related
+ ### nix_related
nixFlakes
nix-prefetch-git
validatePkgConfig
jq
git
- # d_build_related
- rund
+ ### d_build_related
+ ## package manager
dub
+ ## compiler
ldc
+ rund
+ ## linker
+ #lld
+ #mold
+ ## builder
+ #ninja
#meson
- # search related
+ ### sqlite search related
sqlite
- # candy
+ ### candy
starship
];
shellHook = ''