aboutsummaryrefslogtreecommitdiffhomepage
path: root/sundry/spine_search_cgi/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sundry/spine_search_cgi/shell.nix')
-rwxr-xr-xsundry/spine_search_cgi/shell.nix16
1 files changed, 12 insertions, 4 deletions
diff --git a/sundry/spine_search_cgi/shell.nix b/sundry/spine_search_cgi/shell.nix
index 7f37eee..5926e62 100755
--- a/sundry/spine_search_cgi/shell.nix
+++ b/sundry/spine_search_cgi/shell.nix
@@ -3,20 +3,28 @@
pkgs.mkShell {
buildInputs = with pkgs; [(
with pkgs; [
+ # nix_related
nixFlakes
- rund
- dub
- ldc
- sqlite
nix-prefetch-git
validatePkgConfig
jq
git
+ # d_build_related
+ rund
+ dub
+ ldc
+ #meson
+ # search_sqlite_related
+ # search related
+ sqlite
+ # candy
+ starship
]
)];
shellHook = ''
if [[ -e ".envrc" ]]; then
source .envrc
fi
+ eval "$(starship init bash)"
'';
}