aboutsummaryrefslogtreecommitdiffhomepage
path: root/sundry/spine_search_cgi/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sundry/spine_search_cgi/shell.nix')
-rwxr-xr-xsundry/spine_search_cgi/shell.nix38
1 files changed, 18 insertions, 20 deletions
diff --git a/sundry/spine_search_cgi/shell.nix b/sundry/spine_search_cgi/shell.nix
index 5926e62..55ca4ae 100755
--- a/sundry/spine_search_cgi/shell.nix
+++ b/sundry/spine_search_cgi/shell.nix
@@ -1,26 +1,24 @@
#!/usr/bin/env -S nix-shell --pure
{ pkgs ? import <nixpkgs> {} }:
pkgs.mkShell {
- buildInputs = with pkgs; [(
- with pkgs; [
- # nix_related
- nixFlakes
- nix-prefetch-git
- validatePkgConfig
- jq
- git
- # d_build_related
- rund
- dub
- ldc
- #meson
- # search_sqlite_related
- # search related
- sqlite
- # candy
- starship
- ]
- )];
+ buildInputs = with pkgs; [
+ # nix_related
+ nixFlakes
+ nix-prefetch-git
+ validatePkgConfig
+ jq
+ git
+ # d_build_related
+ rund
+ dub
+ ldc
+ #meson
+ # search_sqlite_related
+ # search related
+ sqlite
+ # candy
+ starship
+ ];
shellHook = ''
if [[ -e ".envrc" ]]; then
source .envrc