aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2022-12-19 21:08:28 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2022-12-28 15:51:00 -0500
commit338915b9ef3827762fcbfa3a1143db3e883c7917 (patch)
tree59ba0960fc1907ee72861710a67e585ba06b9b21 /flake.nix
parenttrack markup modifications (from March) (diff)
nix flake, mostly things nix
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..3ef1f17
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,29 @@
+{
+ description = "a sisu like document parser search form";
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable"; # "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ spine.url = "git+file:///home/ralph/grotto/repo/git.repo/projects/doc-reform/code/software/spine";
+ spine.inputs.nixpkgs.follows = "nixpkgs";
+ spine.flake = true;
+ };
+ outputs = { self, nixpkgs, flake-utils, spine }:
+ let
+ version = "0.12.0";
+ supportedSystems = [ "x86_64-linux" ]; # [ "x86_64-linux" "x86_64-darwin" "aarch64-linux" "aarch64-darwin" ];
+ forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
+ nixpkgsFor = forAllSystems (system: import nixpkgs { inherit system; }); # nixpkgs instantiated for supported system types.
+ in {
+ packages = forAllSystems (system:
+ let pkgs = nixpkgsFor.${system};
+ in {
+ default = spine.packages.${system}.default;
+ #vendorSha256 = "sha256-0Q00000000000000000000000000000000000000000=";
+ });
+ devShells = forAllSystems (system:
+ let pkgs = nixpkgsFor.${system};
+ in with pkgs; {
+ devShell = mkShell { buildInputs = [ git dub dmd ldc gdc sqlite ]; };
+ });
+ };
+}