aboutsummaryrefslogtreecommitdiffhomepage
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..3ef1f17
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,29 @@
+{
+ description = "a sisu like document parser search form";
+ inputs = {
+ nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable"; # "github:nixos/nixpkgs";
+ flake-utils.url = "github:numtide/flake-utils";
+ spine.url = "git+file:///home/ralph/grotto/repo/git.repo/projects/doc-reform/code/software/spine";
+ spine.inputs.nixpkgs.follows = "nixpkgs";
+ spine.flake = true;
+ };
+ outputs = { self, nixpkgs, flake-utils, spine }:
+ let
+ version = "0.12.0";
+ supportedSystems = [ "x86_64-linux" ]; # [ "x86_64-linux" "x86_64-darwin" "aarch64-linux" "aarch64-darwin" ];
+ forAllSystems = nixpkgs.lib.genAttrs supportedSystems;
+ nixpkgsFor = forAllSystems (system: import nixpkgs { inherit system; }); # nixpkgs instantiated for supported system types.
+ in {
+ packages = forAllSystems (system:
+ let pkgs = nixpkgsFor.${system};
+ in {
+ default = spine.packages.${system}.default;
+ #vendorSha256 = "sha256-0Q00000000000000000000000000000000000000000=";
+ });
+ devShells = forAllSystems (system:
+ let pkgs = nixpkgsFor.${system};
+ in with pkgs; {
+ devShell = mkShell { buildInputs = [ git dub dmd ldc gdc sqlite ]; };
+ });
+ };
+}