aboutsummaryrefslogtreecommitdiffhomepage
path: root/shell.nix
diff options
context:
space:
mode:
authorRalph Amissah <ralph.amissah@gmail.com>2021-01-28 13:22:50 -0500
committerRalph Amissah <ralph.amissah@gmail.com>2021-01-28 13:22:50 -0500
commit026ca3c8f3f8aa5f3a3a3688c91d3439726c2572 (patch)
treeed8f8d6358cbe5eeb5be94412b798c7916ea2fc4 /shell.nix
parentshell.nix project.nix spine.nix mkDub.nix (diff)
nix build -f default.nix, experimental
Diffstat (limited to 'shell.nix')
-rwxr-xr-xshell.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/shell.nix b/shell.nix
index 941a217..17ccd5b 100755
--- a/shell.nix
+++ b/shell.nix
@@ -4,9 +4,9 @@ pkgs.mkShell {
buildInputs = with pkgs; [
(import ./nix/pkglst/shell-pkgs.nix { inherit pkgs; })
];
+ buildPhase = "nix build -f default.nix";
shellHook = ''
- nix-build
echo "built spine @ ./result/bin/spine"
- nix-instantiate | nix show-derivation | jq
+ #nix-instantiate | nix show-derivation | jq
'';
}